Back to overview
Downtime

All services are unavailable

May 27, 2026 at 6:18pm UTC
Affected services
LilWebsite
LilGit
LilMC

Resolved
Jun 10, 2026 at 11:44am UTC

All issues were resolved. The upgrade was complete.

Updated
Jun 2, 2026 at 2:33pm UTC

We will have some maintenance coming up to fix the issues sometime tomorrow around 2-4

Updated
May 31, 2026 at 5:08pm UTC

Issues still persist. Waiting for Lumos to come back up

Updated
May 30, 2026 at 1:21pm UTC

We are updating the router to accomidate for new solutions to our current isp problem.

Updated
May 30, 2026 at 3:37am UTC

Our ISP, Lumos, is down right now. We will switch to a backup method of connection soon.

Created
May 27, 2026 at 6:18pm UTC

We are investigating the issue now.